Zum Hauptinhalt gehen

ArtikelEdit mit der Standard API

Kommentare

4 Kommentare

  • Bastian Aigner

    Hi Robert,

     

    Hast du mal versucht, die ID statt im XML per GET-Parameter anzugeben? 

    POST /api/ArtikelEdit?id=123

    Oder alternativ könnte es funktionieren, wenn du sie im XML-Body angebist, dann aber mit dem XML-Tag "id_ext":

     

    <?xml version="1.0" encoding="UTF-8"?><request><status><function>ArtikelEdit</function></status><xml><id_ext>86</id_ext><lieferzeitmanuell>3-5 Tage</lieferzeitmanuell></xml></request>

     

    Viele Grüße,

    Basti

    0
  • ruhr.agency

    Hi,

    eine Sache die mir noch auffällt: Versuch im Header als "Content-Type"  "application/xml" statt "application/x-www-form-urlencoded". Ich hab zwar noch keinen Apizugriff mit Artikeledit gemacht, aber bei BestellungEdit ging es bei mir auch nur mit application/xml soweit ich das noch richtig im Kopf hab. Dort hab ich den Endpoint "/api/BestellungEdit" genutzt und hab die Bestellungs-ID im XML selber angegeben und nicht als GET-Parameter. 

    Lars

    0
  • Robert Walther

    Danke euch beiden.

     

    Nutze nun id_ext und der Form halber auch den richtigen Content-Type und siehe da, es läuft.

     

    Robert

    0
  • peter flink

    Robert Walther wenn Du deinen kompletten Request der funtkioniert einmal posten könntest wäre das super. Bei mir tritt leider das selbe Problem auf - ist jedoch mit ext_id nicht gelöst.

    Danke & VG, Peter

    0

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.